See Also

See Also CADBasics 1.0 Help

What is CAD ?

Description

What is CAD/CAM?

CAD Computer Aided Design or Drafting. Inputting lines, arcs, coordinates, dimensions and text for engineering purposes not onto paper but into a data base. The beauty of this is the ability to manipulate the data in many ways during and after completion of any job. There are many types of CAD systems and brand names, but you can break it down into two types, 2D and 3D.

2Dimensional almost like drawing on a drafting board, essentially a flat view usually dimensioned and detailed to some type of standard but is somewhat limited. 3Dimensional is very popular, and with the ability to manipulate 3D Models as if they were actual solid objects, very desirable. Each 3D model is an exact replica of an existing object or idea of an object but in digital format which can be up scaled or down scaled or modified to any specific tolerance. These digital objects are then ready for multiple views, or cross sections, dimensions and details, just like 2D drawings. But 3D models have much more to offer, NC programming can be done to create actual products, see CAM, or even for graphic development for the animation industry, which is also very popular.

CAM Computer Aided Manufacturing, in some cases the manufacturing of parts, fixture gauges, stamping dies, prototype models, moulds etc. The relation to Mach9 Technologies Inc. is not so much Manufacturing but more Computer Aided.

CAM the use of computer generated 3D models,see CAD, to develop specific programs for any particular solid object. Creating a program, cutter path, for an Numeric Control (NC) machine is the most widely used format for cutting various forms, shapes and contours into various materials such as steel, aluminum, tool board, wood, and machinable waxes. There are many other ways to cut materials which are computer controlled as well, and these processes are highly sophisticated in each of their aspects. NC machines are everywhere producing products every day.

Remarks

The term CAD/CAM is a shortening of Computer-Aided Design (CAD) and Computer-Aided Manufacturing (CAM). The term CAD/NC (Numerical Control) is equivalent in some industries.

Well before the development of Computer-aided Design the manufacturing world adopted tools controlled by numbers and letters to fill the need for manufacturing complex shapes in an accurate and repeatable manner, especially for aircraft components. During the 1950's these Numerically-Controlled machines used the existing technology of paper tapes with regularly spaced holes punched in them (think of the paper roll that makes an old-fashioned player piano work, but only one inch wide) to feed numbers into controller machines that were wired to the motors positioning the work on machine tools. The electro-mechanical nature of the controllers allowed digital technologies to be easily incorporated as they were developed.

By the late 1960's Numerically-Controlled machining centers were commercially available incorporating a variety of machining processes and automatic tool changing. Such tools were capable of doing work on multiple surfaces of a workpiece, moving the workpiece to positions programmed in advance and using a variety of tools - all automatically. What is more, the same work could be done over and over again with extraordinary precision and very little additional human input. NC tools immediately raised automation of manufacturing to a new level once feedback loops were incorporated (the tool tells the computer where it is, while the computer tells it where it should be). What finally made NC technology enormously successful was the development of the universal NC programming language called APT (Automatically Programmed Tools). Announced at MIT in 1962, APT allowed programmers to develop postprocessors specific to each type of NC tool so that the output from the APT program could be shared among different parties with different manufacturing capabilities. The development of Computer-aided design had little effect on CNC initially due to the different capabilities and file formats used by drawing and machining programs, but as Cad applications such as SolidWorks and AutoCad incorporate Cam intelligence, and as Cam applications such as MasterCam adopt sophisticated Cad tools both designers and manufacturers are now enjoying an increasing variety of capable Cad/Cam software. Most CAD/CAM software was developed for product development and the design and manufacturing of components and molds, but they are being used by architects with greater frequency.

CAD/CAM software utilizes Cad drawing tools designed ultimately to describe geometries in such a manner that they can be extracted by the Cam portion of the program to define a toolpath that will direct the motion of a machine tool to machine the same shape that was drawn.

Today, over three-quarters of new machine tools incorporate CNC technologies. These tools are used in every conceivable manufacturing sector, including many affecting building technologies. CNC technology is related to Computer-Integrated Manufacturing (CIM), Computer-Aided Process Planning (CAPP) and other technologies such as Group Technology (GT) and Cellular Manufacturing. Finally, Flexible Manufacturing Systems (FMS) and Just-In-Time Production (JIT) are important concepts made possible by Numerically-Controlled Machines, affecting the integration of manufacturing cells, productivity and quality in a wide variety of strategic industries.

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Getting Started

Description

When you start a CAD application you can start a new drawing or open an existing one in order to modify it. You can add or remove drawing objects in the drawing or add or remove collections. You can also run commands to modify the drawing or change the displayed part of the drawing(with zoom or pan command). You can save the drawing in several formats like vdi, vdf, vdp, bmp, wmf, emf, gif, jpg, tga, tif, png. You can also print the drawing. See here a screenshot of a sample CAD editor application.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


CAD Editor

Description

A simple CAD Editor

Click on the redlined areas for more information

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Drawing Objects

Description

Drawing objects are all the objects that are seen on a drawing, like lines, circles etc.

Each one of them are specified by their geometry.

Remarks

These objects can be :

  • Line
  • Circle
  • Polyline
  • Arc
  • Dimension
  • Image
  • Polyface
  • PolyHatch
  • Rectangle
  • Ellipse
  • Text
  • Insert of block
  • 3DFace


Line

Description

A single line segment.

Lines can be one segment or a series of connected segments, but each segment is a separate line object.

Use the line object if you want to edit individual segments.

Remarks

Line is specified by two points, the Start point and the End point.
When the line has thickness then the extrusion vector of the line defines the direction of the thickness.


Circle

Description

A full circle is defined by its CenterPoint and its Radius.

Circle is drawn in the plane that is defined by CenterPoint and ExtrusionVector.

Remarks

Ways to design a circle:

Center,Radius

With this method user sets the center point and the radius of the circle

2 Points

With this method user sets two opposite points of the circle.Basically the two points define the diameter of the circle(position and size).

3 Points

With this method user sets three points that belong to the circle.


Polyline

Description

This object is a 2D/3D line composed of line and arc (bulges) segments. Polyline is specified by an array of Vertexes (points). When the Polyline has thickness then the extrusion vector of the polyline defines the direction of the thickness.

Polyline can be Open or Closed, can be SPLine and be filled with a color or a hatch.

Remarks

Bulge Geometry :


Arc

Description

A circular arc is defined by the center point, the radius, the start angle and the end angle.

An arc is always drawn anti-clockwise from the StartAngle to the EndAngle.

The StartPoint and EndPoint properties of an arc are calculated through the StartAngle, EndAngle and Radius properties.

The ExtrusionVector is always vertical to the arc. Arc is drawn in the plane that is defined by CenterPoint and ExtrusionVector

Remarks

Ways to design an arc:

Center Point,Radius,Start Angle,End Angle

With this method user has to set Center Point,Radius,Start angle and End angle of the arc

With this method user has to set 3 points of the arc


Dimension

Description

Dimensioning is the process of adding measurement annotation to a drawing. User has many ways to dimension objects and many ways to format dimensions. You can create dimensions for a wide variety of object shapes in many different orientations. You can create dimension styles to format dimensions quickly and ensure that dimensions in your drawing conform to industry or project standards.

Dimensions show the measurements of objects, the distances or angles between objects, or the distance of a feature from an origin you specify. User has three basic types of dimensioning: linear, radial, and angular. Dimensions can be horizontal, vertical, aligned, rotated,angular. A linear dimension measuring the distance between two points which is displayed parallel to the points being measured. In aligned dimensions, the dimension line is parallel to the extension line origins. The extension line origins are specified using the DefPoint1 and DefPoint2 properties.

Angular dimensions measure the angle between two lines or three points.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Image

Description

It is a basic object for inserting images in the drawing.
Inserted Images can be BMP, GIF, JPG, PNG and TIFF

When the inserted image is an 1-bit Image (B&W) then the background color of the image (usually the white) is shown transparent and the other color is shown black or white, depending on the background color. This is useful for drawings to be scanned and then inserted as images in other drawings.

Image has a Scale property that is used to resize keeping the aspect ratio of the image.

The image is defined by InsertionPoint, Rotation, Width and Height.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Polyface

Description

User defines a PolyFace by specifying each vertex and then associating those vertices with faces in the mesh.

In essence , polyface is a number of 3dfaces combined to an object.
User can explode the polyface into 3dfaces.

User can create complex 3D objects.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


PolyHatch

Description

Polyhatch is a collection which contain PolyLine Objects.

Every PolyLine represents one Hatch which can be excluded from the whole collection or be included to the collection. You can control this using CombineList property. If the CombineList index = 16 then it is excluded else it is included.

Remarks

You can Use Item, Count methods and for each to access the PolyLine Objects of Polyhatch object.
When your drawings have Polyhatch objects and are saved in third party formats then Polyhatches are converted to Hatches and vice versa.

Polyhatch objects do not have thickness.
Polyhatch objects in 3D are displayed as solids filled with the FillColor.


Ellipse

Description

An ellipse is defined when we know:

a) length of axis 1 and the end point of axis 2

b) center point and the end points of the two axis.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Text

Description

If you want to add a text in the drawing you can use the text command.

You have to set the start point where the text will begin. Then you have to set the rotation angle of the text. After that you can specify the text. Notice that the text will be drawn with the current Text Style of the document.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Insert

Description

Places a drawing or a named block into the current drawing.

When you insert a block, you determine its location (or its name if it exists in the drawing), scale factor, and rotation angle.Inserting a block creates an object called a block reference because it references a block definition stored in your current drawing. Notice that in order to insert a block , this must be an existing block that previously has been created or that it will exist as an independent drawing.

Remarks

The insert object can be exploded to the objects that consist of.


3DFace

Description

3dface creates a three or four sided surface anywhere in 3D space. You can specify different Z coordinate values for each corner point of a 3D face.

Remarks

Is an object which have a vertexlist with 4 items as Point(x,y,z) in World CS.

The fourth point can be the same as first (to make a triangle).


Collections

Description

The Collections are very important. The drawing objects (lines, text, dimensions etc) take their properties, when they are created, from these collections. The collections are:

  • Layers
  • Layouts
  • TextStyles
  • DimStyles
  • Blocks
  • Lights
  • Selections
  • Section Clips
  • Linetypes
  • Lineweights

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Layers

Description

Layer is the equivalent of the overlay used in paper-based drafting. It is the primary organizational tool in VectorDraw, and you can use it to group information by function and to enforce linetype, color, and other standards.
Organizing Layers and the objects on Layers make it easier to manage the information in your Drawings.

When you put one layer over another then the result is the complete drawing.

Having kindred objects on the same layer it is very helpfull in order to organise the drawing.

Properties:

  • layer name
  • color of the entities
  • line type of the entities
  • line weight of the entities
  • if it is participate or not in the drawing(thawed or frozen)
  • locked or not

Remarks

When you begin a new drawing, VectorDraw creates a special layer named 0. By default, layer 0 is assigned color number 7 (white or black depending upon your background color), the CONTINUOUS linetype and a lineweight of Default (the default setting is .01 inch or .25 mm). Layer 0 cannot be deleted or renamed.

All new objects are added to the active layer if no layer is specified.

Using VectorDraw you can Freeze (Hide), Thaw (Show) and Lock layers.

By controlling whether a Layer's state is Thaw or Frozen you can change the appearance of your drawing to display only the information on the Layers that are visible. Freezing unused Layers will help the performance of VectorDraw.

In the drawing below (Picture 1) there are 3 types of items : walls (the lines and Polylines with red color), doors&windows (Blue color) and furniture (Magenta).
These objects are teamed and drawn in different layers. Walls placed on layer "WALLS", Doors&windows are placed on layer "WIN_DOORS" and furniture are placed on layer "FURNITURE".

Picture 1

All layers are Thawed. All information is shown.
In big drawings this might confuse the user.

Picture 2

Layer "FURNITURE" is Freezed. The furniture is not shown.
A civil engineer would like to view the drawing this way.

Picture 3

All layers except the "WALLS" are freezed.
This is the basic information.


Layouts

Description

Layout is used to compose or lay out your model drawing for printing. A layout may consist of a title block, one or more viewports, and annotations. As you create a layout, you can design floating Viewport configurations to visualize different details in your drawing.

A layout is a paper space environment that simulates a sheet of paper. In a layout, you can create and position viewport objects, and you can add a title block or other geometry. You can create multiple layouts in a drawing to display various views. Each layout displays the drawing as it will be printed on the sheet of paper.

Typically, when you begin designing a layout environment, you step through the following process:
Create a model drawing.
Activate or create a layout.
Insert a title block.
Create floating viewports and position them in the layout.
Set the view scale of the floating viewports.
Print your layout.

Remarks

Sample of a Layout (Paper Space) :


TextStyles

Description

TextStyle is a named, saved collection of settings that determines the appearance of text strings.

You can create your own text styles which can have specific fonts and text height. You can also specify if the text will be underlined,bold etc.

There is no limit to the number of text styles you can create in your drawing.

Remarks

The active text style determines the appearance of new text created in the drawing. StyleName of text object will get the value of ActiveTextStyle property.

When you enter text, it uses the current text style, which sets the font, size, and other text characteristics. If you want to create text using a different text style, you can make another text style active.


DimStyles

Description

A dimension style is a group of dimension settings that determines the appearance of a dimension .

Remarks

The active dimension style determines the appearance of new dimensions created in the drawing.
To change the style of an existing dimension, use the StyleName property found on the dimension.

When you create a dimension, the current dimension style is associated with that dimension. The dimension retains this dimension style unless you apply a new dimension style to it or set up dimension style overrides.

The picture below shows where the vdDimstyle's properties apply to vdDimension objects.


Blocks

Description

A block is a collection of objects you can associate together to form a single object, or block definition. You can insert, scale, and rotate a block in a drawing. You can explode a block into its component objects, modify them, and redefine the block definition.

Remarks

Blocks streamline the drawing process. For example, you can use blocks to

  • Build a standard library of frequently used symbols, components, or standard parts.
    You can insert the same block numerous times instead of re-creating the drawing elements each time.
  • Revise drawings efficiently by inserting, relocating, and copying blocks as components rather than individual geometric objects.
  • Save disk space by storing all references to the same block as one block definition in the drawing database.

When you insert a block in your drawing, you are creating a block instance. Each time you insert a block instance, you assign a scale factor and rotation angle to the inserted block. You can also scale a block instance using different values in any coordinate (X, Y, Z) direction. Blocks make it possible for you to organize your drawing tasks in a systematic way, so that you can set up, redesign, and sort the objects in your drawings and the information associated with them.


Lights

Description

It is the collection of the Lights objects.

Adding lights to your drawing is the simplest way to improve the appearance of your models. You can use lights to illuminate a whole model or to highlight selected objects and parts of objects in your drawing.

Remarks

You can add as many lights you want but you can only enable 8 including the Default Light.

This is an example of a sphere with two lights.


Selections

Description

One or more selected objects that specify a selection for processing as a single unit.

For example instead of copying objects to another location one at a time, you can select all objects and copy the selection once.

Remarks

There is no limit to the number of selection sets you can create in your drawing.
However, there can be only one instance of the SelectionSets Collection.
The SelectionSets Collection object is predefined for each drawing.


Section Clips

Description

VectorDraw uses section clipping planes to hide an area of the drawing. This SectionClip defines the side of the drawing that will be visible. The rest will be hidden.

Remarks

The visible plane is defined in the vdSectionClip object by defining the OriginPoint and the Direction vector. The direction of that vector defines the visible area. The area in the opposite direction will be hidden.
Direction with the OriginPoint define the plane that will do the section clipping. Their values are always in World Coordinating System.

Multiple vdSectionClip objects will show the common viewable area of all. This allows an unobstructed interior view of a 3D drawing by hiding the defined area from view.


Linetypes

Description

With linetype you can select a specific type for a line which all the new lines will be.

Any future object in the drawing will be added with the new selected line type.

TIPS:Instead of changing line type any time you want a different line type, you can create different layers with the desirable line type.

Remarks

VectorDraw uses penstyle property to define the linetype.

Default value is VdPenByLayer (PenStyle by Layer). When object is a Layer then the default value is VdPenSolid.

Penstyle is scaleable.The scale is set from the ActiveDocument.LineTypeScale property.

If the entity is part of a block and it's layer name is "0" and pen style is VdPenByLayer (by Layer) then, when the block is inserted, entity takes the pen style value of the inserted object. This can be done the same if you use for Penstyle the value VdPenByBlock (by block).

These are some examples of linetypes:


Lineweights

Description

With lineweight you can select a specific width for a line which all the new lines will be.

Using lineweights, you can create heavy and thin lines to show cuts in sections, depth in elevations, dimension lines and tick marks, and varying object thicknesses in details.

Remarks

TIPS:Instead of changing lineweight any time you want a different lineweight, you can create different layers with the desirable lineweight.

Any future object in the drawing will be added with the new selected lineweight.

In model space, lineweights are displayed in pixels and do not change when zoomed in or out. Thus, you should not use lineweights to represent the exact width of an object in model space. For example, if you want to draw an object with a real-world width of 0.5 inches, do not use a lineweight, instead, use a polyline with penwidth equal to 0.5 inches to represent the object.


Commands

Description

In order to edit designed objects you have to run the specific command and then select the object(or objects) you want to edit. The same procedure must be done when you want to create new objects from one or more drawing objects.

Alternative, you can choose firstly the objects and then run the command. However not every command accepts preselected objects.Also not every command accepts multiple selected objects.

Remarks

The commands are used to edit the drawing objects, like splitting a line to two smaller lines, delete a circle etc. The commands are the following:

  • Select
  • Erase
  • Undo
  • Redo
  • Copy
  • Offset
  • Fillet
  • Move
  • Trim
  • Extend
  • Mirror
  • Array
  • Break
  • Scale
  • Rotate
  • Explode
  • Purge
  • Zoom
  • Pan
  • View3D


Select

Description

When you run an edit command (which allows multiple object selection) you have to select the objects(or object) that you want to edit.

There are many ways to select objects:

  • You can click one by one the objects you want to select.
  • Crossing method. With this method you have to set a rectangle by setting the two opposite corners(first set one of the two right corners) of the rectangle. Then all the objects that are included entirely in the rectangle or have an intersectection point with the rectangle , will be selected.
  • Window method. It is similar with the crossing method , but only the objects that are included entirely in the rectangle will be selected(Also you have to set one of the left corners of the window).
  • Select All. With this method you can select all the objects of the drawing
  • Select Last. With this method you can select the last drawn object.
  • Select Previous. With this method you can select the objects that was selected before the completion of the last edit command(Notice that previous command does not take effect when the previous command was erase or undo.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Erase

Description

With the erase command you can delete one or more objects of the drawing.

If you want to erase multiple objects you have to execute the select method.

After the erase command, the objects no more "exist" in the document and in the collection they belonged to, however the objects still exist as "deleted" objects in memory. So with undo command you can get them back to the drawing.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Undo

Description

Many times you want to cancel one or more commands that took place.This can be done with the undo command.

You can also undo a group of commands that took place. The group undo takes place by the opposite order.If for example 100 commands were executed, undo command cancels first the 100th command , then the 99th etc.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Copy

Description

With copy command you can copy one or more objects of the drawing.

When copy command starts, user has to select objects. Then the user is prompted to select two points. These two points define the "copy vector" and can either belong to the selected objects or not.The first point specifies the begining of the "copy vector" and the second point the end of it.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Offset

Description

With Offset command you can create a new object , in parallel direction and in specified distance from the original object which is used as pattern for the new object.

When you execute offset command , you are promt to select an object. Then you have to specify the offset distance which is the distance that the new object will be draw from the original object. Then you have to set the side that the object will be draw because there are two sides.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Fillet

Description

With the fillet command you can connect two lines , two arcs, or one arc with a line(these two objects must have at least one common point either visible, or in their extension) , with an arc with a specific radius. The value of the radius has some restrictions depending the position of the objects. If radius=0 then simply the objects are either extended until they intersect each other in one point(if there was not an intersection point) either trimmed(if an intersection point is visible).

You can also insert fillet arcs at vertex of specified index of a polyline where two line segments meet if the specified radius is enough small to fit into lines.

If the radius is bigger then it is ignored for the specific vertex.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Move

Description

With move command you can move one or more drawing objects.

In order to take place the move command you have(after selecting the objects or object) to define two points that define the distance and the direction of the movement.

The firts point defines the beginning of the "movement vector" and the second the end of the vector.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Trim

Description

With trim command you can trim objects at a cutting edge defined by other objects.

First select the objects that define the cutting edges at which you want to trim an object and then the object.
Objects that can be trimmed include arcs, circles, elliptical arcs, lines.

Notice that the trim command do not function if the objects do not intersect.

At the example below there are some lines that were trimmed.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Extend

Description

With extend command you can extend lines,arcs,polylines until they intersect with some other object which is used as limit of the extension.

Firstly you have to select the objects that consist the limits of the extension. Then you have to choose a point at an object that you want to extend. If the object you want to extend does not intersect with above objects then nothing will happen.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Mirror

Description

With mirror command you can create the symmetrical of one or more objects reflected by an axis defined by the user.

First you have to select the objects you want to mirror. Then you have to set the axis , by setting the first point of mirror line and then the second. At this point you have to choose if the source ojects will be deleted or not.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Array

Description

Creates multiple copies of objects in a pattern.

There are the Rectangular Array and the Polar Array.

With the rectangular array you can create an array defined by a number of rows and columns of copies of the selected object.
First you have to select the objects.Then you have to define number of rows and number of columns of the rectangle, the distance between rows and the distance between columns.

With the Polar Array you can create an array by copying the selected objects around a center point.
First you have to select the objects.Then you have to set the center point and next you have to define the numbers of the copy objects that will be created and the fill angle(if you put for example 360 then the object will be created like in the below example). At the end you are prompt to choose if the object will be rotated or not.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Break

Description

With break command you can divide one object into two objects, or you can remove one part of it(this part will be defined by two points that you have to pick).

First you have to select the object.Then you have to define the first break point and the second break point.When you pick this points , the part which is defined by the two points will be deleted from the object.

Remarks

The two points can be the same point. In this case you only explode the object into two other objects(for example you can cut a line into two lines).

If break command runs over a circle , you have to set two different points in order to see a result because a circle cannot break in one point. After break command the circle becomes arcs.


Scale

Description

With scale command you can increase or decrease the size of one or more objects.

First you have to select one or more objects.Then you have to pick one point ,which is going to be the base point. Next step is to specify the scale factor .

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Explode

Description

With explode command you can break compound objects , like inserts ,dimensions ,polylines etc into their sub entities.

Remarks

Here are some objects that can be exploded:

  • vd3DFace explode to one vdPolyline
  • vdDimension explode to vdLines, vdText(s), and vdInserts (the arrows)
  • vdInsert explode to the entities that is consist of. (If there are Inserts inside Blocks then you may need to apply more than 1 explode to get the simplies entities)
  • vdPolyface explode to vd3DFace(s)
  • vdPolyHatch explode to vdPolyline(s)
  • vdPolyline explode to vdLine(s) and/or vdArc(s)
  • vdRect explode to vdPolyline
  • vdText explode to vdPolylines(only texts with fontfile SHX).TTF(true type font) texts are not exploded


Purge

Description

With purge command you can reject some tables of the drawing like layers,textstyles,linetypes etc that you do not use in the drawing and you do not want anymore.

In purge command you have to specify what objects you want to delete(PurgeFlag). You can also see with purge command which tables are not currently used in the drawing.

Remarks

PurgeFlag can be one of the following:
ALL Removes all unused named objects layers, textstyles, dimstyles, blocks and images.
LAYERS Removes all unused named layers
TEXTSTYLES Removes all unused named textstyles
DIMSTYLES Removes all unused named dimstyles
BLOCKS Removes all unused named blocks
IMAGES Removes all unused image information.
GETLAYERS fills the return value with the array of all unused named layers (the objects still exist)
GETTEXTSTYLES fills the return value with the array of all unused named textstyles (the objects still exist)
GETDIMSTYLES fills the return value with the array of all unused named dimstyles (the objects still exist)
GETBLOCKS fills the return value with the array of all unused named blocks (the objects still exist)


Zoom

Description

Zoom command allows the user to increase or decrease the apparent size of objects , so the user can control the part of the drawing that is included in the screen.

Zoom command is a transparent command.
Transparent commands are commands that can be invoked when another command is active.

Remarks

There are several ways to execute the zoom command:

  • "E"(Extends) Zooms to display the drawing extents
  • "P"(Previous) Zooms to display the previous view
  • "W"(Window) Zooms to display an area specified by two opposite corners of a rectangular window. User must specify these two corners.
  • "A"(All) zooms to the drawing limits or current extents, whichever is greater.
  • "S"(Scale) Zooms the display at a specified scale factor. For example, entering 2 doubles the apparent display size of any objects from what it would be if you were zoomed to the limits of the drawing. Entering 0.5 causes each object to be displayed at half its current size on the screen.

    • Send comments on this topic.


Pan

Description

You can shift the location of your view by using pan or by using the window scroll bars. Like panning with a camera, pan does not change the location or magnification of objects on your drawing; it changes only the view.

Pan command is a transparent command.
Transparent commands are commands that can be invoked when another command is active.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


View3D

Description

With View3D command you can change the current view of the drawing.

Remarks

The View3D function when is called it also changes the Current Coordinate System (CCS) to World Coordinate System (WCS).

Arguments
Description |  | Parameter
 | Sets the view point to top | VTOP
 | Sets the view point to bottom | VBOTTOM
 | Sets the view point to left | VLEFT
 | Sets the view point to right | VRIGHT
 | Sets the view point to front | VFRONT
 | Sets the view point to back | VBACK
 | Sets the view point to southwest isometric | VISW
 | Sets the view point to southeast isometric | VISE
 | Sets the view point to northeast isometric | VINE
 | Sets the view point to northwest isometric | VINW
 | Shades the objects between the polygon faces and displays materials if there are attached on object colors else the result is the same like SHADE | RENDER
 | You can start a continuous motion with it , by rotating the coordinate system around X (vertical motion dy) and/or around Y Axis (Horizontal motion dx) | VROT
 | Shades the objects between the polygon faces and does not displays materials. Coloring the objects surfaces with it's colors. | SHADE
 | Combines the SHADE and WIRE options | SHADEON
 | Displays the objects using 3D wire frame representation and hides lines representing back faces. | HIDE
 | Displays the objects using lines and curves to represent the boundaries. | WIRE
 | Sets the view point to World system. | VWORLD
 | Sets the view point to any angle. | VPOINTANGLE


Limits

Description

While designing in paper user has a specific space to make the drawing , with CAD user can have unlimited space to design the drawing.

The drawing limits are two-dimensional points in the world coordinate system that represent the lower-left and upper-right boundaries. You cannot impose limits on the Z direction.

Remarks

When limits checking is turned on , the drawing limits restrict the coordinates you can enter to within the rectangular area. Drawing limits also determine the area of the drawing that can display grid dots, the area displayed by one of the scale options of zoom, and the minimum area displayed by zoom all.


Coordinates

Description

Coordinates are being expressed in drawing units.Drawing units are not expressing particular units(meters,inches etc).

In this part user have to make some assumptions in order to define that the coordinates of the drawing mean particular units(meters,inches etc).

For example:

For a mechanichal drawing we can make the assumption for example: where one drawing unit defines one millimeter(1 D.U=1mm)

For a architectural/technical drawing we can make the assumption for example: where one drawing unit defines one meter(1 D.U=1m)

This can be very helpfull in designing,dimensioning,retrieving informations from the drawing(distances,area calculations)

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Viewport

Description

Viewports are areas that display different views of your model. As you work, you can split the drawing area into one or more adjacent rectangular views known as model viewports. In large or complex drawings, displaying different views reduces the time needed to zoom or pan in a single view. Also, errors you might miss in one view may be apparent into others.

ViewPorts are treated as rectangle drawing objects which display views and can be moved or resized.

They can be created only in entity list collection of a layout and not in Model.

Remarks

Those rectangles filled with the image of the model space objects in different scales depend from the ViewSize and the ViewCenter property. This way in one paper you can print out diffent views (with differnt scales) of the same drawing (Model Space) or parts of this drawing.

In viewports commands like Pan, Zoom and View3D of vdCommandAction objects can be applied, only when Viewport is Active (See ActiveViewport property of Layout object) and SpaceMode property of vdLayout has the value SPACEMODE_MODEL.


Grid

Description

The grid is a rectangular pattern of dots that extends over the area you specify as the drawing limits. Using the grid is similar to placing a sheet of grid paper under a drawing. The grid helps you align objects and visualize the distances between them.

The grid is not printed. If you zoom in or out of your drawing, you may need to adjust grid spacing to be more appropriate for the new magnification.

Remarks

User can modify the x,y grid spacing(distance between the dots horizontally or vertically).\


Snap

Description

Snap mode restricts the movement of the crosshairs to intervals that you define. When Snap mode is on, the cursor seems to adhere, or "snap," to an invisible rectangular grid. Snap is useful for specifying precise points with the arrow keys or the pointing device.

Remarks

User can modify the x,y snap spacing.

You can also set the base point of the snap.This point defines the bottom left point of the snap.

If you need to draw along a specific alignment or angle, you can change the snap angle. This rotation realigns the crosshairs on the screen to match the new angle.


Ortho

Description

A setting that limits pointing device input to horizontal or vertical (relative to the current snap angle and the user coordinate system).

That means that if ortho mode is on and you want to draw for example one line , this line will be parallel to x or y axis.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Osnap

Description

An object snap(Osnap) mode specifies a snap point at an exact location on an object. osnap specifies running object snap modes, which remain active until you turn them off.

Remarks

The snap point on an object can be:

  • Endpoint
  • Midpoint
  • Center
  • Insertion
  • Perpendicular
  • Nearest
  • Apparent Intersection
  • Node (point)
  • Quadrant
  • Tangent
  • Intersection (one point)


Units

Description

You can specify the type of the current unit of measurement and the precision for the current units as also the current angle format and the precision for the current angle display.

Remarks

Type of measurement can be:

Scientific 1.6449E+001
Decimal 16.4492
Engineering 1' - 4.4492"
Architectural 1' - 4 7/16"
Fractional 16 7/16
Windows desktop (It takes the settings of the regional settings)

Angle format can be:

Decimal degrees
Degrees/minutes/seconds
Gradians
Radians


Print

Description

By pressing the print preview button you can see the default Print Preview dialog of VectorDraw.

At the top right window you can set the margins either in millimeters or in inches.

Orientation can be change to landscape or portrait.

With Scale you can set the scale of the drawing in the print page. For example 1mm of the page will represent 0.35747 drawing units.

You can also turn B&W to on in order to print in black and white mode.

In print area you can either set extends to include the whole drawing or you can choose a window.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Extrusion Vector

Description

The extrusion vector defines the plane that the object will be drawn and is always vertical in that plane.

Remarks

If the entity has thickness then the thickness follows extrusion vector direction.
For example the default value of extrusion vector is (0,0,1) (the Z axis direction) if the object is drawn in the XY plane.


Rectangle

Description

The rectangle is defined by InsertionPoint, Rotation, Width and Height.

Rectangle is drawn in the plane that is defined by InsertionPoint and ExtrusionVector

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Redo

Description

If you accidentally undo one command, then you can restore it by executing redo command.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


Render

Description

Creates a photorealistic or realistically shaded image of a three-dimensional wireframe or solid model.

Render produces an image using information from a scene, the current selection set, or the current view.

Remarks

Vectordraw uses a Render engine. Some of this engine's properties and methods are exported through vdRender object. Basically these are usefull when the events below are fired :

  • Draw
  • DrawEntity
  • DrawAfterEntity
  • DrawAfter
  • DrawBackground
  • CommandActionDraw

VectorDraw renders the hole scene in a memory device context (memory bitmap). Then this bitmap is viewed. This default render object is returned from Render method of the component.

It is useful to draw in Low-Level without the need to add drawing objects.

VectorDraw renders in a Device, that can be a memory bitmap or a Device (hDC) that belongs to a Window (hWnd).

The basic properties of this vdRender object that are needed to transform the D.U. (Drawing Units) to Window-Pixels are :

  • Upper Left corner of the Device (Left and Top in pixels)
  • Width in pixels
  • Height in pixels
  • View Center (GetViewCenter) in D.U. of current view, 2D point
  • View Size the height of the view in D.U. that defines the zoom.
  • vdMatrix object transformation that is used to transform the objects coordinates from World CS to curent view coordinate system.


Rotate

Description

With rotate command you can rotate one or more objects around a base point.

First you have to select the object or objects and then specify the base point.Then you have to select an angle in radians to rotate the object.

Original Text Rotated text by 45 radians

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Wednesday, June 23, 2004


TextStyle

Description

TextStyle is a named, saved collection of settings that determines the appearance of text strings.

You can create your own text styles which can have specific fonts and text height. You can also specify if the text will be underlined,bold etc.

There is no limit to the number of text styles you can create in your drawing.

Remarks

The active text style determines the appearance of new text created in the drawing. StyleName of text object will get the value of ActiveTextStyle property.

When you enter text, it uses the current text style, which sets the font, size, and other text characteristics. If you want to create text using a different text style, you can make another text style active.

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Friday, April 23, 2004